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ClearClick® Vintage 
Suitcase Turntable 

Quick Start Guide & User’s Manual 

3-Year Warranty + 

FREE USA-Based Tech Support 

If you have any issue or question regarding this product, 

contacting us directly is the fastest way to resolve the 

issue. We are ClearClick®, a small USA-based business, 

and we stand behind our products with a 3-year warranty & 

free USA tech support. If you have any issues with our 

product, please contact us at support@clearclick.tech. 

www.ClearClick.tech 

FCC ID:2ASDT-VT3031

mailto:support@clearclick.tech
http://www.clearclick.tech/
https://manuals.plus/m/480e8992056d0853ca344e53d3c636f0780289ca702cded9ab9d26526533a993
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Register Your Product & Browse Our Products

Thank you for your purchase! Make sure you register your 

product & check out our other unique & easy-to-use technology 

at: 

www.ClearClick.tech 

Safety Precautions 

1. Do not disassemble the unit.

2. Do not operate the unit around water or rain. Do not operate

the unit around any kind of machines or appliances (other than 

computers). 

3. Turn off and unplug the unit when not in use.

4. Do not allow young children to use this device.

Thank You!

Thank you for your purchase of the ClearClick® Vintage Suitcase 

Turntable! We appreciate your business. 

At ClearClick®, we try to make our technology as clear to 

understand and use as possible. But if you get stuck at any point, 

you qualify for FREE USA-based tech support as a ClearClick® 

customer. Just email us at: support@clearclick.tech  

(Make sure you explain your issue in detail and tell us that you’re 
using our ClearClick® Vintage Suitcase Turntable). Our 

USA-based tech support team members will normally reply to you 

within 24-48 business hours.) 

http://www.clearclick.tech/
mailto:support@clearclick.tech
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To get started with your ClearClick® Vintage Suitcase Turntable, 

please see the quick start guide on the following pages. 

 

What’s In The Box 

• ClearClick® Vintage Suitcase Turntable 

• Power Adapter 

• USB Cable 

• User’s Manual 

 

NOTE: If you believe you are missing any parts, or if you received 

a part that is broken, please contact us directly at 

parts@clearclick.tech. For all other technical issues or support, 

please contact us at support@clearclick.tech.  

 

 

 

 

 

   “Convert Your Cassette Tapes To CD or 

MP3 in Just 3 Easy Steps…” 

 

 

ALSO FROM 

Introducing the Cassette2USB™ 

Converter. Visit Our Website: 

www.Cassette2USB.com 

mailto:parts@clearclick.tech
mailto:support@clearclick.tech
http://www.cassette2usb.com/
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QUICK START – Listening To Records 

1. Plug the power adapter into the back of the turntable. Plug the 

other end into any electrical outlet. 

2. Switch the knob on the top of the turntable to “PHONO.” 
Turn on the power switch. The power LED will light up red. 

3. Remove the white plastic protective cover on the turntable 

needle. Remove the black protective twist ties on the turntable 

“arm”. 
 

4. Place a record on the turntable and select the desired speed 

(33/45/78) according to the record. 

NOTE: If you are playing a 45 RPM record, use the included 

45 RPM adapter located in the holder near the tone arm. 

 

5. Remove any protective twist ties from the tone arm. Open the 

tone arm clip to release the tone arm. Place the tone arm onto 

the record. The turntable will begin to spin after the arm is 

moved toward the record. 

 

6. Turn the VOLUME CONTROL KNOB to adjust the volume. 

 

7. If the Auto Stop Control Switch is turned ON, the record will 

stop automatically when finished. If Auto Stop Control Switch 

is turned OFF, the record will NOT stop automatically when 

finished. 

NOTE: The AUTO STOP function works with most 33 RPM vinyl 

records. However, it may not work with all records.  
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QUICK START – Playing Music via Bluetooth

1. Plug the power adapter into the back of the turntable. Plug the

other end into any electrical outlet.

2. Switch the knob on the top of the turntable to “BT.”
Turn on the power switch. The power LED will light up blue.

3. On your phone, tablet, or other Bluetooth device, scan for

Bluetooth devices and connect to the one named “Vintage
Turntable.”

4. The power LED will become solid blue once the turntable is

connected to your Bluetooth device.

5. Start playing music on your Bluetooth device. Turn the

VOLUME CONTROL KNOB to adjust the volume. (NOTE:

You may need to adjust the volume on your phone or

Bluetooth device as well.)

QUICK START – Playing Music via AUX IN

1. Plug the power adapter into the back of the turntable. Plug the

other end into any electrical outlet.

2. Switch the knob on the top of the turntable to “LINE IN.”

3. Connect your phone or MP3 player to the AUX IN port using

an “aux in” (3.5mm to 3.5mm) audio cable (not included).

4. Start playing music on your iPod or MP3 player, and adjust

the volume both on the device and on the turntable.
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QUICK START – Converting Records To 

MP3’s Using Your PC or Mac
1. On your PC or Mac, load and install the included software CD.

Alternatively, you can download the software from:

PC: http://www.ClearClickSoftware.com/PC-Setup.exe  

MAC: http://www.ClearClickSoftware.com/MAC-Setup.dmg 

(After the file has downloaded it, double-click the setup file to 

install the software.) 

If you are using a PC, the setup wizard will appear. Click 

“Next” in the prompts until the software is fully installed. 

If you are using a Mac, drag the “Audacity” software icon into 
your Applications folder to install the software. 

2. After the software is installed, plug the turntable into your PC

or Mac using the included USB cable.

3. Open the “Audacity” software that you just installed on your
PC or Mac. NOTE: the turntable must already be plugged in

BEFORE opening the software.

4. In the software, click “Edit -> Preferences” (or Audacity ->

Preferences on Mac).

5. Under the “Devices” section, set the “Recording Device” to the
correct settings, as shown below. It will read something like:

http://www.clearclicksoftware.com/PC-Setup.exe
http://www.clearclicksoftware.com/MAC-Setup.dmg
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“AudioDevice on USB Bus” or “USB Audio Device/USB 
Microphone”).” Also, set Channels to “2 (Stereo).” 

6. Load a record onto the turntable and start playing it (as

described in the first Quick Start Guide)

7. Click the “Record” icon in the software, and your record will
start transferring to your computer!

8. When the record has finished playing, click the “Stop” icon in
the software.

9. To save your recorded audio, click File -> Export Audio

(Audacity -> Export Audio on Mac).

10. Choose the name, location, and file type that you’d like to
save your audio file as, and click “Save.” We recommend

saving in “MP3” format.

11. The first time that you save an MP3 recording, the software

may prompt you for a file called “lame_enc.dll.” This file can
be downloaded at:

http://www.clearclicksoftware.com/MP3-encoder.zip

(Download the ZIP file and extract the DLL file. When

Audacity asks for the “lame_enc.dll” file, point it to this file.)

http://www.clearclicksoftware.com/MP3-encoder.zip
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12. Your audio will be saved as a digital MP3 file! 

 

How To Remove Noise From Your Recordings 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Drag the cursor over a 

portion of the audio track to 

select a part which 

contains ONLY noise, no 

music, as shown below. 

 

 

2. Click the Effect menu → Noise 

Reduction. 
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3. Click “Get Noise Profile”. The Noise Removal window will now 
close automatically. 

 

4. Select the entire track of audio you wish to remove noise from. 

If you wish to clean up the entire recording, use “Select All” under 
the “Edit Menu”.  

 

5. Repeat Step 2 to bring up the “Noise Removal” Window. 
 

6. Adjust the amount of audio that you would like to filter by 

moving the slider in the “Noise Removal” window. We 
recommend using the minimum noise removal for optimum sound. 

Note: you can preview the audio before removing the noise by 

clicking on ‘Preview’. 
 

7. Click the ‘Remove Noise’ button. 
 

8. Remember to re-export your file if you want to save the 

changes. 
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Turntable Diagram 
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1. 45 RPM adapter holder – Holds the included 45 RPM 

adapter. When not using the adapter, please place it in this 

holder. 

2. AUX IN port 

3. Lift lever 

4. Function switch knob 

5. 33 / 45/78 RPM switch – This switch controls the RPM of 

the turntable platter. 

6. Power on/off and volume control knob 

7. Power indicator 

8. Headphone jack 

9. AUTO STOP ON/OFF switch 

10. Tone arm lock 

11. Ceramic cartridge 

12. Platter – Place your record here. Please use the 45 RPM 

adapter, if the spindle is the incorrect size. 

13. USB jack – Use to connect to computer for converting the 

records to digital MP3 

14. DC IN jack 

15. RCA output – Use to connect to external speakers (not 

included) 
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Frequently Asked Questions (FAQ) 

 

1. What computers is the USB turntable compatible with? 

 

The turntable is compatible with both Microsoft Windows 10, 8, 7, 

Vista, XP and Apple Mac OS X. 

 

2. When I record audio from my converter, I don’t get any 
sound. 

 

Make sure you have the correct recording device set. 

 

PC: Set the “Recording Device” to “USB Microphone/Audio 

Device” or “AudioDevice On USB Bus”. 
MAC: In the software, click Audacity → Preferences and set the 

“Recording Device” to “USB Microphone/USB Audio Device” 
(Device name may vary slightly) 

 

3. How do I save my audio recordings as MP3? 

 

After recording your audio recording, use the File/Audacity → 

Export Audio feature inside the software. 

 

The first time you do this, you will be asked to locate a file called 

“lame_enc”  to add this feature to the software. This file can be 

downloaded at: 

http://www.clearclicksoftware.com/MP3-encoder.zip 

(Download the ZIP file and extract the DLL file. When Audacity 

asks for the “lame_enc.dll” file, point it to this file.) 

http://www.clearclicksoftware.com/MP3-encoder.zip
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4. How do I use the turntable to import music into iTunes? 

 

First, convert your record to WAV or MP3 format and save it on 

your PC. You can then import your recordings into iTunes and put 

them on your iPod/iPad/iPhone. 

 

5. My audio recordings don’t sound good. 
 

1) Try setting the speed selector to the correct speed setting 

based on the type of record you are listening to. 

2) Turn down the “Recording” / “Microphone” volume in the 
software. 

3) Under File/Audacity → Preferences, set “Channels” to “2 
(Stereo)” in the “Devices” section. 
4) If your recordings still are low quality, it is possible that your 

original vinyl record's quality has degraded over time. 

5) If you are running the noise removal feature, try recording 

without using the noise removal feature. Running this feature on 

recordings without enough noise to remove will result in poor 

recordings. 

 

6. The software doesn’t record audio correctly or I can’t hear 
anything during playback. 

 

1) After recording, unplug your turntable from your PC. Then 

export your recording as a WAV or MP3 file and exit the software. 

Finally, play your music in software such as Windows Media 

Player or iTunes. 

2) Make sure you have the correct recording device set. In the 

software, set the “Recording Device” to something like “USB 
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Audio Device” or “USB Microphone.” 

7. How do I split up my recording into individual tracks?

     First, use the mouse to select a track. Do this by clicking 

and dragging between the silences (flat lines). Use the “Zoom 
In/Out” tool if necessary. 

Then, click File/Audacity → “Export Selected Audio.” Select a 

location to save the file. Repeat the process for the remaining 

tracks that are recorded. When finished, you may exit Audacity 

and say “no” when asked to save the file. 

8. Is there a way to make the audio transfer faster?

Transfers must be done at normal speed. This is because the 

turntable records the actual audio that is emitted by the player. 

Need Help With 

Anything? We Are Here 

To Help! Email Us At: 

support@clearclick.tech 

mailto:support@clearclick.tech
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www.ClearClick.tech 

Federal Communications Commission Notice
This device complies with part 15 of the FCC Rules. Operation is subject to 
the following two conditions: (1) This device may not cause harmful 
interference, and (2) this device must accept any interference received, 
including interference that may cause undesired operation.
Any Changes or modifications not expressly approved by the party 
responsible for compliance could void the user's authority to operate the 
equipment.
Note: This equipment has been tested and found to comply with the limits for 
a Class B digital device, pursuant to part 15 of the FCC Rules. These limits 
are designed to provide reasonable protection against harmful interference in 
a residential installation. This equipment generates uses and can radiate 
radio frequency energy and, if not installed and used in accordance with the 
instructions, may cause harmful interference to radio communications. 
However, there is no guarantee that interference will not occur in a particular 
installation. If this equipment does cause harmful interference to radio or 
television reception, which can be determined by turning the equipment off 
and on, the user is encouraged to try to correct the interference by one or 
more of the following measures:
-Reorient or relocate the receiving antenna.
-Increase the separation between the equipment and receiver.
-Connect the equipment into an outlet on a circuit different from that to which 
the receiver is connected.
-Consult the dealer or an experienced radio/TV technician for help.

The device has been evaluated to meet general RF exposure requirement. 
The device can be used in portable exposure condition without restriction.

http://www.clearclick.tech/

