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RTL8722DM 

 
Build and Debug Environment Setup – IAR 
 
This document illustrates how to build Realtek low power Wi-Fi software under IAR SDK environment.  

  

https://manuals.plus/m/1048c7a3e7b4f40d57a1f67dfa0997095e390385fc8e9402dd8912483c5ec005
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1 IAR Build Environment Setup 
This chapter illustrates how to setup IAR development environment for Realtek Ameba-D SDK, including building projects, downloading images 
and debugging. 

1.1 Requirement 

1.1.1 IAR Embedded Workbench 

IAR provides an IDE environment for code building, downloading, and debugging. Check “IAR Embedded Workbench” on http://www.iar.com/, 
and a trail version is available for 30 days.  
 
Note: To support ARMv8-M with Security Extension (Ameba-D HS CPU, also called KM4), IAR version must be 8.30 or higher. 

1.1.2 J-Link or RLX Probe 

If you need to download images or debug code for Ameba-D with IAR, then a J-Link adapter or a RLX Probe is necessary.  
 
Note: For Ameba-D CPU, the J-Link version must be v9 or higher. 

1.2 Hardware Configuration 

The hardware block diagram of Ameba-D demo board is shown in Fig 1-1. 
 USB TO UART: supply power and print logs, baud rate is 115200 bps. 
 SWD: SWD interface, used for image downloading and debugging with IAR. 
 Reset button: reset Ameba-D to run firmware after IAR completes downloading. 

 

Fig 1-1 Ameba-D demo board 
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1.2.1 Antenna description 

The DUT has three types of antennas, both of which are 2.4 & 5GHz dual band antennas. The information is as follows. PIFA & Dipole antennas 
are connected with module by IPEX. 
1) PCB Onboard Antenna, 2.4G peak gain 4.1dbi, 5G peak gain 3.9dbi. 
2) PIFA Antenna, 2.4G peak gain 3.5dbi, 5G peak gain 5dbi. 
3) Dipole Antenna, 2.4G peak gain 3dbi, 5G peak gain 5dbi. 

1.2.2 Connecting with J-Link 

Refer to Fig 1-2 and Fig 1-3 to connect Ameba-D SWD interface with J-Link. 
 

J-Link

 

Fig 1-2 J-Link and SWD connection diagram 
 

 

Fig 1-3 J-Link and Ameba-D SWD connection 

1.2.3 Connecting with RLX Probe 

Refer to Fig 1-4 and Fig 1-5 to connect Ameba-D SWD interface with RLX Probe. 
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Fig 1-4 RLX Probe and SWD connection diagram 

 

Fig 1-5 RLX Probe and Ameba-D SWD connection 

1.3 How to Use IAR SDK? 

1.3.1 IAR Project Introduction 

Because Ameba-D is a dual-core CPU platform, two workspaces are provided to build for each core in 
project\realtek_amebaD_va0_example\EWARM-RELEASE. 
 Project_lp_release.eww (KM0 workspace) contains the following projects: 

 km0_bootloader 
 km0_application 

 Project_hp_release.eww (KM4 workspace) contains the following projects: 
 km4_bootloader 
 km4_application 
 km4_secure 

 
Each project in KM4 workspace has different build configurations, as Table 1-1 shows. 

Table 1-1 Build configurations for KM4 project 
Project Build Configuration Configure TrustZone Enable MP 
km4_bootloader km4_bootloader - is1 N N 

km4_bootloader - tz2 Y N 
km4_application km4_application - is N N 

km4_application - tz Y N 
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km4_application - is (mp3) N Y 
km4_application - tz (mp) Y Y 

km4_secure km4_secure - tz Y N 
km4_secure - tz (mp) Y Y 

Note: 
1. The configuration items with “-is” are ignore secure configuration, which are designed for applications that do not use TrustZone. 
2. The configuration items with “-tz” are TrustZone configuration, which are designed for applications that use TrustZone. 
3. The configuration items with “mp” are mass production configuration, which are designed for generating MP image. 
 
 For applications that do not use TrustZone, users should apply ignore secure configurations as Table 1-2 shows. The km4_secure project 

which contains Trustzone-protected code, is not used. 
 For applications that use TrustZone, users should apply TrustZone configurations as Table 1-2 shows. 

Table 1-2 Configurations for project with/without TrustZone 
Project TrustZone Normal Image MP Image 
km4_bootloader N km4_bootloader - is km4_bootloader - is 

Y km4_bootloader - tz km4_bootloader - tz 
km4_application N km4_application - is km4_application - is (mp) 

Y km4_application - tz km4_application - tz (mp) 
km4_secure Y km4_secure - tz km4_secure - tz (mp) 
 
At the top of the Workspace window, there is a drop-down list where you can choose a build configuration for a specific project. 
 

Configuration 
drop-down menu ① 

② ③ 

 

Fig 1-6 How to choose a build configuration 

1.3.2 IAR Build 

When building SDK for the first time, you should build both KM0 project and KM4 project. Other times, you only need to rebuild the modified 
project. 

1.3.2.1 Building KM0 Project 

The following steps show how to build KM0 project: 
(1) Open project\realtek_amebaD_va0_example\EWARM-RELEASE\Project_lp_release.eww. 
(2) Make sure km0_bootloader and km0_application are in Workspace. Click Project > Options, General Options > Target > Processor 

Variant > Core, verify the CPU configurations according to Fig 1-7. 
(3) Right click the project and choose “Rebuild All”, as Fig 1-8 shows. The km0_bootloader and km0_application should compile in order. 
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Fig 1-7 KM0 processor options 
 

 

Fig 1-8 Building KM0 project 
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Note: After building each project, IAR will pop up a command prompt window to execute post-build action to generate images from 
executable files. This may takes several seconds. Don’t stop it while it is in progress. After post-build action is completed, the window 
would disappear automatically. 

 

 
 
(4) After compile, the images km0_boot_all.bin and km0_image2_all.bin can be seen in project\realtek_amebaD_va0_example\EWARM-

RELEASE\Debug\Exe\km0_image. 

1.3.2.2 Building KM4 Project 

The following steps show how to build KM4 project: 
(1) Open project\realtek_amebaD_va0_example\EWARM-RELEASE\Project_hp_release.eww. 
(2) Refer to 1.3.1 and choose the build configurations for each project according to your application. 
(3) Click Project > Options, General Options > Target > Processor Variant > Core, verify the CPU configurations according to Fig 1-9. 

 

Fig 1-9 KM4 processor options 
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(4) Right click the project and choose “Rebuild All”, as Fig 1-10 shows. The km4_bootloader, km4_secure and km4_application should 
compile in order. 

 

 

Fig 1-10 Building KM4 project 
 
Note: 
 When TrustZone is enable, the km4_secure project must be built before the km4_application project. When TrustZone is not used, there 

is no need to compile the km4_secure project. 
 After building each project, IAR will pop up a command prompt window shown in the figure below to execute post-build action to 

generate images from executable files. This may takes several seconds. Don’t stop it while it is in progress. After post-build action is 
completed, the window would disappear automatically. 

 

 
 
(5) After compile, the images km4_boot_all.bin and km0_km4_image2.bin can be seen in project\realtek_amebaD_va0_example\EWARM-

RELEASE\Debug\Exe\km4_image. For MP configurations, the km0_km4_image2_mp.bin would be generated instead. 
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1.3.3 IAR Download 

The generated images can be downloaded in two ways: 
 IAR J-Link or RLX Probe SWD (introduced in the next section) 
 Ameba-D ImageTool, refer to Image Tool User Guide for more information. 
 
Ameba-D demo board supports using J-Link and RLX Probe SWD to download and debug. Image of each project can be download individually. 
 
Note: Considering KM4 is powered-on by KM0, you should make sure that KM0 has boot up already before downloading images to KM4. 
Otherwise, for J-Link, J-Link can’t connect to KM4 and show the error message as Fig 1-11 shows. For RLX probe, RLX Probe driver can’t be 
opened under KM4. 
 

 

Fig 1-11 J-Link cannot find KM4 
 
As a result, if the Flash memory is empty, the sequence to download images is: 
(1) Download for km0_bootloader and km0_application projects 
(2) Click Reset button on demo board to make KM0 boots up 
(3) Download for km4_bootloader and km4_application projects 
 
During development, if Flash memory is not empty and KM0 can boot up successfully, then you can download updated images to KM4 directly, 
and there is no need to re-download for KM0. 
 
The following steps show how to download image for the target project with IAR. If there is an error like Fig 1-24 displayed in IAR window, refer 
to 1.3.4.3. 
(1) Choose the target project display in Workspace window, for example, km4_bootloader as Fig 1-12 shows. 
(2) If using J-link debugger, check whether the J-link debugger setting is correct. 

a) Click Project > Options > Debugger > Setup > Driver, and choose “J-Link/J-Trace”, as Fig 1-13 shows. 
b) Click Debugger > J-Link/J-Trace > Connection > Interface, and choose “SWD”, as Fig 1-14 shows. 
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Fig 1-12 Switching to the target project view 
 

 

Fig 1-13 J-Link debugger setup 
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Fig 1-14 J-Link interface setup 
 
(3) If using RLX Probe, check whether the RLX Probe setting is correct. 

a) Click Project > Options > Debugger > Setup > Driver, choose “GDB Server” and don not choose “Run to”, as Fig 1-15 shows. 
b) Click GDB Server > GDB Server, and put correct value in “TCP/IP address or hostname”, as Fig 1-16 shows. The value should be: 

localhost, port number. 
 KM4: The default port numbers is 3333, which is set in project\realtek_amebaD_va0_example\EWARM-

RELEASE\probe\cm4\rlx_probe0.cfg. 
 KM0: The default port numbers is 2331, which is set in project\realtek_amebaD_va0_example\EWARM-

RELEASE\probe\cm0\rlx_probe0.cfg. 
c) Open RLX Probe in project\realtek_amebaD_va0_example\EWARM-RELEASE\probe\cm4\cm4_RTL_Probe, as Fig 1-17 shows. 
Note: The board must be reset before opening the RLX Probe, otherwise the connection may fail. 

 

 

Fig 1-15 RLX Probe setup 
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Fig 1-16 RLX Probe interface setup 
 

 

Fig 1-17 RLX Probe window 
 
(4) Click Project > Download > Download active application, image downloading starts. 

When downloading, Ameba-D prints the log, as Fig 1-18 shows. You can check the log to see if download is successful. 
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Fig 1-18 Downloading log 
 
(5) You can also erase all parts of the Flash memory if necessary. 
 

 

Fig 1-19 Erasing Flash memory 

1.3.4 IAR Debug 

You can debug or trace KM0 and KM4 system individually with J-Link or RLX Probe SWD. 
 
Note: Considering KM4 is power-on by KM0, you should make sure that KM0 has already boot up before debug KM4. For KM0, there is no such 
requirement because KM0 is power-on immediately after reset. 
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1.3.4.1 J-Link Debug 

Follow the steps to debug and trace code of target project with IAR by J-Link: 
(1) Set the target project as active project and verify the debugger configurations as step (1) and (2). 
(2) Click Project > Download and Debug or Project > Debug without Downloading. 

 Download and Debug: downloads the application and debug the project object file. If necessary, a make will be performed before 
download to ensure the project is up to date.  

 Debug without Downloading: debug the project object file 
(3) When starting IAR C-SPY to debug, it will firstly reset the target CPU and run to the main function, as Fig 1-20 shows. 
(4) Toggles a breakpoint at the statement or instruction that contains or is located near the cursor in the source window. The “Toggle 

Breakpoint” button is on the debug toolbar, as Fig 1-21 shows. 
 

 

Fig 1-20 Running to main() when debug 
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Fig 1-21 Toggle breakpoint 
 
(5) You can trace code step by step with “Step Into” or “Go” until triggering a breakpoint. These function buttons are available on toolbar. 

1.3.4.2 RLX Probe Debug 

Follow the steps to debug and trace code of target project with IAR by RLX Probe: 
(1) Set the target project as active project and verify the debugger configurations as step (1) and step (3). 
(2) Click Project > Attach to Running Target. 
(3) Set the target address. 

When starting debug with RLX Probe, it will firstly reset the target CPU. If you want to run to a target address at first, you can set the PC 
address in project\realtek_amebaD_va0_example\EWARM-RELEASE\probe\cm4\rlx_probe0.cfg. The method is that uncomment 
“ew .pc = 0xxxxxxxxx” and change the address to the appointed value, as Fig 1-22 and Fig 1-23 shows. 

 

 

Fig 1-22 Setting the target address 
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Fig 1-23 Running to the target address when debug 
 
(4) Toggles a breakpoint at the statement or instruction that contains or is located near the cursor in the source window. The “Toggle 

Breakpoint” button is on the debug toolbar, as Fig 1-21 shows. 
(5) You can trace code step by step with “Step Into”, or “Go” until triggering a breakpoint. These function buttons are available on toolbar. 

1.3.4.3 IAR Debug or Download Error 

Because Ameba-D has two CPU cores, and a post-build script will be run after make, sometimes the debug or download thread cannot get the 
correct AXF file for debug or download, the error like Fig 1-24 happens. 
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Fig 1-24 IAR debug or download error 
 
To avoid this error, you should build manually before debug or download, and disable auto-build from Tools > Options > Project > Make before 
debugging, as Fig 1-25 shows. 
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Fig 1-25 IDE options 

1.3.5 IAR Memory Configuration 

1.3.5.1 Configuring Memory from IAR IDE 

In order to allow users to manage memory flexibly, there are some configurations to put some code into certain memory region. 
In IAR workspace, there are “@PSRAM” and “@SRAM” group. The code in “@PSRAM” group would be linked and loaded into PSRAM, and the 
code in “@SRAM” group would be linked and loaded into SRAM. The rest of code will be placed on Flash and execute in place. 
 
Note: Considering only SRAM and PSRAM contains secure regions, the code in km4_secure project should be placed either in “@PSRAM” or in 
“@SRAM”. It can’t be placed outside these two groups. 
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Fig 1-26 Memory location configuration 

1.3.5.2 Configuring Memory from ICF File 

IAR uses ICF (IAR Configuration File) to configure memory allocation, so users can configure memory allocation by ICF file. 
 
ICF file of Ameba-D location: 
 “project\realtek_amebaD_va0_example\EWARM-RELEASE\ rtl8721dhp_image2_is.icf” for ignore secure project 
 “project\realtek_amebaD_va0_example\EWARM-RELEASE\ rtl8721dhp_image2_tz.icf” for TrustZone project 
 
If having a good understand of the format of ICF, users can modify the section location in ICF file.  

1.4 How to Build Sample Code? 

The example source code is located in project\realtek_amebaD_va0_example\example_sources. To build sample code, you should copy the 
“main.c” file in the target example to project\realtek_amebaD_va0_example\src\src_hp and replace the original one. 
 
For example, you can copy “main.c” from project\realtek_amebaD_va0_example\example_sources\I2C\mbed\i2c_int_mode\src to use 
i2c_int_mode example code, as Fig 1-27 shows. 
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Fig 1-27 Building sample code 

1.5 Used Memory Size Calculation 

This section explains how to calculate used memory size by users in IAR project, whose version is IAR 8.30.1 or higher. You can refer to 
“km4_application.map” to observe them after project build. This file can be found in the following folders: 
 Project folder: project\realtek_amebaD_va0_example\EWARM-RELEASE\Debug\List\km4_application 
 IAR GUI’s folder: Output 

 

1.5.1 Memory Section 

 A7 (PSRAM): This section is read-write data in PSRAM (0x2000000 to 0x23FFFFF). 
 BTTRACE: This section is reserved for BTTRACE. 
 A5 (XIP): This section is read-only data in XIP. 
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 A4 (SRAM): This section is read-write data in SRAM. 
 P1 (SRAM): This is BSS section in SRAM. 

1.5.2 Memory Size 

1.5.2.1 Memory Size in SRAM 

There are two sections resident in SRAM, which are A4 and P1. As we can see from the map file, for standard SDK, these two sections use 
almost all of the memory space from SRAM (476KB). 
 
 A4 has size 0x17ad7. 

 
 
 P1 has size 0x5dfc8. 

 
 
So totally 0x17ad7 + 0x5dfc8 = 470K bytes memory in SRAM is used. 
 
The total SRAM space is defined in project\realtek_amebaD_va0_example\EWARM-RELEASE\rtl8721d_memory_layout_is.icf. 

define symbol __ICFEDIT_region_HS_BD_RAM_NS_start__  = 0x10005000; 
define symbol __ICFEDIT_region_HS_BD_RAM_NS_end__  = 0x1007C000-1; 

 
For this case, the total size of SRAM is 0x1007C000 ─ 0x10005000 = 0x77000 = 476K bytes, there is still 6K (= 476K ─ 470K) bytes free SRAM 
space. 

1.5.2.2 Memory Size in PSRAM 

There is one section in PSRAM called A7, the memory space from PSRAM (4MB). 
 
A7 has size 0x54800. 

 
 
So totally 0x54800 = 338K bytes memory in PSRAM is used. 

1.5.2.3 Memory Size in XIP 

XIP can only place text section, so there is only one section called A5. 
 
A5 has size 0x8afe8. 
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So totally 0x8afe8 = 555K bytes memory in XIP is used. 

1.5.2.4 Available Heap Size 

When calculating total used memory size, available heap size after WLAN association and BT connection needs to be considered. In the above 
case, it is 56096 bytes. 

 
 
Finally, you can use total SRAM 476K bytes to subtract these sections of memory to obtain totally free global memory and free heap in SRAM.  
 
Formula is as below:  
 SRAM free global memory: 476K ─ “A4” ─ “P1” = 476*1024 ─ 96983 ─ 384968= 5473 (bytes) 
 Available heap: 56096 bytes. 
 Totally free SRAM memory and heap: 5473 + 56096 = 61569 (bytes) 
 Totally free PSRAM memory: 4*1024*1024 – 338 * 1024 (A7) = 3848192 (bytes) 

 

 

 

1.6 warning 

1.6.1  Federal Communication Commission Interference Statement 

     This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to Part 15 of the FCC Rules.  
These limits are designed to provide reasonable protection against harmful interference in a residential installation.  This equipment generates, 
uses and can radiate radio frequency energy and, if not installed and used in accordance with the instructions, may cause harmful interference 
to radio communications.  However, there is no guarantee that interference will not occur in a particular installation.  If this equipment does 
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cause harmful interference to radio or television reception, which can be determined by turning the equipment off and on, the user is 
encouraged to try to correct the interference by one of the following measures: 
 
- Reorient or relocate the receiving antenna. 
- Increase the separation between the equipment and receiver. 
- Connect the equipment into an outlet on a circuit different from that 

to which the receiver is connected. 
- Consult the dealer or an experienced radio/TV technician for help. 
 
This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) This device may not cause harmful 
interference, and (2) this device must accept any interference received, including interference that may cause undesired operation. 
 
FCC Caution: Any changes or modifications not expressly approved by the party responsible for compliance could void the user's authority to 
operate this equipment. 
 
IMPORTANT NOTE: 
FCC Radiation Exposure Statement: 
This equipment complies with FCC radiation exposure limits set forth for an uncontrolled environment. This equipment should be installed and 
operated with minimum distance 20cm between the radiator & your body. 
 
This device and its antenna(s) must not be co-located with any other transmitters except in accordance with FCC multi-transmitter product 
procedures. 
Refering to the multi-transmitter policy, multiple-transmitter(s) and module(s) can be operated simultaneously without C2PC.  
 
This module is intended for OEM integrator. The OEM integrator is responsible for the compliance to all the rules that apply to the product into 
which this certified RF module is integrated. 
Additional testing and certification may be necessary when multiple modules are used. 
 
List of applicable FCC rules 
This module has been tested and found to comply with part 22, part 24, part 27, 15.247 and 15.407 requirements for Modular Approval. 
The modular transmitter is only FCC authorized for the specific rule parts (i.e., FCC transmitter rules) listed on the grant, and that the host 
product manufacturer is responsible for compliance to any other FCC rules that apply to the host not covered by the modular transmitter grant 
of certification. If the grantee markets their product as being Part 15 Subpart B compliant (when it also contains unintentional-radiator digital 
circuity), then the grantee shall provide a notice stating that the final host product still requires Part 15 Subpart B compliance testing with the 
modular transmitter installed. 
 
USERS MANUAL OF THE END PRODUCT: 
In the users manual of the end product, the end user has to be informed to keep at least 20cm separation with the antenna while this end 
product is installed and operated. The end user has to be informed that the FCC radio-frequency exposure guidelines for an uncontrolled 
environment can be satisfied. The end user has to also be informed that any changes or modifications not expressly approved by the 
manufacturer could void the user's authority to operate this equipment. If the size of the end product is smaller than 8x10cm, then additional 
FCC part 15.19 statement is required to be available in the users manual: This device complies with Part 15 of FCC rules. Operation is subject to 
the following two conditions: (1) this device may not cause harmful interference and (2) this device must accept any interference received, 
including interference that may cause undesired operation. 
 
LABEL OF THE END PRODUCT: 
The final end product must be labeled in a visible area with the following " Contains TX FCC ID: TX2-RTL8722DM ". If the size of the end product 
is larger than 8x10cm, then the following FCC part 15.19 statement has to also be available on the label:  This device complies with Part 15 of 
FCC rules. Operation is subject to the following two conditions: (1) this device may not cause harmful interference and (2) this device must 
accept any interference received, including interference that may cause undesired operation. 
 

1.6.2 Industry Canada Statement 

 
This device complies with Industry Canada’s licence-exempt RSSs. Operation is subject to the following two conditions: 
(1) This device may not cause interference; and 
(2) This device must accept any interference, including interference that may cause undesired operation of the device. 
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Le présent appareil est conforme aux CNR d'Industrie Canada applicables aux appareils radio exempts de licence. L'exploitation est autorisée 
aux deux conditions suivantes:  
(1) l'appareil ne doit pas produire de brouillage, et  
(2) l'utilisateur de l'appareil doit accepter tout brouillage radioélectrique subi, même si le brouillage est susceptible d'en compromettre le 
fonctionnement." 
 
Radiation Exposure Statement 
This equipment complies with IC radiation exposure limits set forth for an uncontrolled environment. This equipment should be installed and 
operated with minimum distance 20 cm between the radiator & your body. 

 
Déclaration d'exposition aux radiations: 
Cet équipement est conforme aux limites d'exposition aux rayonnements ISED établies pour un environnement non contrôlé. Cet équipement 
doit être installé et utilisé avec un minimum de 20 cm de distance entre la source de rayonnement et votre corps. 
 
RSS-247 Section 6.4 (5) (6) (for local area network devices, 5GHz) 
The device could automatically discontinue transmission in case of absence of information to transmit, or operational failure. Note that this is 
not intended to prohibit transmission of control or signaling information or the use of repetitive codes where required by the technology.  
 
The device for operation in the band 5150–5250 MHz is only for indoor use to reduce the potential for harmful interference to co-channel 
mobile satellite systems; 
The maximum antenna gain permitted for devices in the bands 5250–5350 MHz and 5470–5725 MHz shall comply with the e.i.r.p. limit; and 
The maximum antenna gain permitted for devices in the band 5725–5825 MHz shall comply with the e.i.r.p. limits specified for point-to-point 
and non point-to-point operation as appropriate. 
 
L'appareil peut interrompre automatiquement la transmission en cas d'absence d'informations à transmettre ou de panne opérationnelle. 
Notez que ceci n'est pas destiné à interdire la transmission d'informations de contrôle ou de signalisation ou l'utilisation de codes répétitifs 
lorsque cela est requis par la technologie. 
 
Le dispositif utilisé dans la bande 5150-5250 MHz est réservé à une utilisation en intérieur afin de réduire le risque de brouillage préjudiciable 
aux systèmes mobiles par satellite dans le même canal; 
Le gain d'antenne maximal autorisé pour les dispositifs dans les bandes 5250-5350 MHz et 5470-5725 MHz doit être conforme à la norme e.r.p. 
limite; et 
Le gain d'antenne maximal autorisé pour les appareils de la bande 5725-5825 MHz doit être conforme à la norme e.i.r.p. les limites spécifiées 
pour un fonctionnement point à point et non point à point, selon le cas. 
 
This device is intended only for OEM integrators under the following conditions: (For module device use) 
1) The antenna must be installed such that 20 cm is maintained between the antenna and users, and 
2) The transmitter module may not be co-located with any other transmitter or antenna. 
As long as 2 conditions above are met, further transmitter test will not be required. However, the OEM integrator is still responsible for testing 
their end-product for any additional compliance requirements required with this module installed. 
 
Cet appareil est conçu uniquement pour les intégrateurs OEM dans les conditions suivantes: (Pour utilisation de dispositif module) 
1) L'antenne doit être installée de telle sorte qu'une distance de 20 cm est respectée entre l'antenne et les utilisateurs, et 
2) Le module émetteur peut ne pas être coïmplanté avec un autre émetteur ou antenne. 
 
Tant que les 2 conditions ci-dessus sont remplies, des essais supplémentaires sur l'émetteur ne seront pas nécessaires. Toutefois, l'intégrateur 
OEM est toujours responsable des essais sur son produit final pour toutes exigences de conformité supplémentaires requis pour ce module 
installé. 
 
IMPORTANT NOTE: 
In the event that these conditions can not be met (for example certain laptop configurations or colocation with another transmitter), then the 
Canada authorization is no longer considered valid and the IC ID can not be used on the final product. In these circumstances, the OEM 
integrator will be responsible for re-evaluating the end product (including the transmitter) and obtaining a separate Canada authorization. 

 
NOTE IMPORTANTE: 
Dans le cas où ces conditions ne peuvent être satisfaites (par exemple pour certaines configurations d'ordinateur portable ou de certaines co-
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localisation avec un autre émetteur), l'autorisation du Canada n'est plus considéré comme valide et l'ID IC ne peut pas être utilisé sur le produit 
final. Dans ces circonstances, l'intégrateur OEM sera chargé de réévaluer le produit final (y compris l'émetteur) et l'obtention d'une 
autorisation distincte au Canada. 

 
End Product Labeling 
This transmitter module is authorized only for use in device where the antenna may be installed such that 20 cm may be maintained between 
the antenna and users. The final end product must be labeled in a visible area with the following: “Contains IC:6317A-RTL8722DM”. 
 
Plaque signalétique du produit final 
Ce module émetteur est autorisé uniquement pour une utilisation dans un dispositif où l'antenne peut être installée de telle sorte qu'une 
distance de 20cm peut être maintenue entre l'antenne et les utilisateurs. Le produit final doit être étiqueté dans un endroit visible avec 
l'inscription suivante: "Contient des IC: 6317A-RTL8722DM ". 
 
Manual Information To the End User 
The OEM integrator has to be aware not to provide information to the end user regarding how to install or remove this RF module in the user’s 
manual of the end product which integrates this module. 
The end user manual shall include all required regulatory information/warning as show in this manual. 
Manuel d'information à l'utilisateur final 
L'intégrateur OEM doit être conscient de ne pas fournir des informations à l'utilisateur final quant à la façon d'installer ou de supprimer ce 
module RF dans le manuel de l'utilisateur du produit final qui intègre ce module. 
Le manuel de l'utilisateur final doit inclure toutes les informations réglementaires requises et avertissements comme indiqué dans ce manuel. 
 


